Proxy Authentication Required

Feb 25, 2009 at 4:38 AM
Edited Feb 25, 2009 at 4:44 AM

I am getting the following error when I run RSBuild.
[PublishTask::Validate]: The request failed with HTTP status 407: Proxy Authentication Required.
My config file looks like this:

<?xml version="1.0" encoding="utf-8" ?><o:p></o:p>

<Settings><o:p></o:p>

      <Globals><o:p></o:p>

            <Global Name="ReportServer">http://localhost/ReportServer$SQLI02</Global><o:p></o:p>

            <Global Name="ReportServerPath">localhost\SQLI02</Global><o:p></o:p>

      </Globals><o:p></o:p>

      <ReportServers><o:p></o:p>

            <ReportServer Name="RS1" Protocol="http" Host="${ReportServer}" Path="${ReportServerPath}" Timeout="30" /><o:p></o:p>

      </ReportServers><o:p></o:p>

      <DataSources><o:p></o:p>

            <DataSource Name="DataSource1" Publish="true" Overwrite="false" TargetFolder="nETSReports" ReportServer="RS1"><o:p></o:p>

                  <ConnectionString>data source=localhost\SQLI02;initial catalog=nETS</ConnectionString><o:p></o:p>

                  <CredentialRetrieval>Store</CredentialRetrieval><o:p></o:p>

                  <WindowsCredentials>False</WindowsCredentials><o:p></o:p>

                  <UserName></UserName><o:p></o:p>

                  <Password></Password><o:p></o:p>

            </DataSource><o:p></o:p>

      </DataSources><o:p></o:p>

      <Reports><o:p></o:p>

            <!-- Search Detail Reports --><o:p></o:p>

            <ReportGroup Name="SearchDetail" DataSourceName="DataSource1" TargetFolder="nETSReports"<o:p></o:p>

                  ReportServer="RS1" CacheTime="10080"><o:p></o:p>

                  <Report Name="Reco Summary"><o:p></o:p>

                        <FilePath>Details\OTCTradeReco.rdl</FilePath><o:p></o:p>

                  </Report><o:p></o:p>

            </ReportGroup><o:p></o:p>

      </Reports><o:p></o:p>

</Settings>

Mar 6, 2009 at 11:25 AM
You should be able to solve proxy authentication problems using a RSBuild.exe.config file in the same directory as RSBuild.exe with for example the following content:
<configuration>
<system.net>
<defaultProxy enabled="true" useDefaultCredentials="true" />
</system.net>
</configuration>
See MSDN for more complicated proxy configuration if necessary.