XML Configuration file error

Topics: Developer Forum
Dec 17, 2007 at 3:06 PM
I need an idea of how to setup the RSBuild.config file.

data source - CredentialRetrieval - What value have i to use. I am specifying Username and password in the config file itself.
I don't want DBExecutions section. I just want to publish the data sources and reports. I don't want to execute db scripts.

It is not taking data source username and password. I am gettin the error "Message = "The request failed with HTTP status 401: Unauthorized."". When I am seeing in the quick watch, It is showing null for username and password.

My config file is as follows,
<?xml version="1.0" encoding="utf-8" ?>
<Settings>
<Globals>
<Global Name="ReportServer">DEVSERVER</Global>
<Global Name="ReportServerPath">reportserver</Global>
</Globals>
<ReportServers>
<ReportServer Name="RS1" Protocol="http" Host="${ReportServer}" Path="${ReportServerPath}" Timeout="0" />
</ReportServers>
<DataSources>
<DataSource Name="DEVSERVER" Publish="true" Overwrite="false" TargetFolder="Data Sources Test" ReportServer="RS1">
<ConnectionString>Data Source=DEVSERVER;Initial Catalog=DairyQueen</ConnectionString>
<CredentialRetrieval>Store</CredentialRetrieval>
<WindowsCredentials>false</WindowsCredentials>
<UserName>sa</UserName>
<Password>password</Password>
</DataSource>
<DataSource Name="DotNetNuke" Publish="true" Overwrite="false" TargetFolder="Data Sources Test" ReportServer="RS1">
<ConnectionString>Data Source=DEVSERVER;Initial Catalog=DotnetNuke</ConnectionString>
<CredentialRetrieval>Store</CredentialRetrieval>
<WindowsCredentials>false</WindowsCredentials>
<UserName>sa</UserName>
<Password>password</Password>
</DataSource>
</DataSources>
<Reports>
<!-- Search Detail Reports -->
<ReportGroup Name="EmployeeReports" DataSourceName="DEVSERVER" TargetFolder="EmployeeReports"
ReportServer="RS1" CacheTime="10080">
<Report Name="EmployeeHoursAndWages" CacheTime="60">
<FilePath>EmployeeReports\Employee Hours And Wages.rdl</FilePath>
</Report>
</ReportGroup>
</Reports>
<!--<DBExecutions>
<DBExecution DataSourceName="DataSource1">
<DBFilePath>SQL\Load\Search\Search.LOAD.sql</DBFilePath>
<DBFilePath>SQL\Load\CachedMenus.LOAD.sql</DBFilePath>
</DBExecution>

</DBExecutions>-->
</Settings>
And also I am seeing error in the config file "The 'settings' element not declared"

It will be very gooda dn thank full, If any one replying me about this.

Thanks,
Muniappan Kandasamy
Coordinator
Mar 2, 2009 at 12:40 AM
Make sure to run RSBuild.exe with a config file name other than RSBuild.config to avoid Configuration exceptions.